
 

 

 

 

 

 

RaceTCS is designed for motorsport use. 

 

Incorrect installation of RaceTCS might result in damage to RaceTCS or other car components. 

 

RaceTCS holds no responsibility for damages caused by improper installation or use. 

 

Read the manual before attempting to install the device or ask a professional for help. 
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1. Requirements 

RaceTCS works with petrol engines that meet following requirements: 

 Sequential Fuel Injection (one injection once per 2 crank revs).  

Batch/bank injection is also supported (two injections per 2 crank revs). 

RaceTCS does not support fuel cut for Direct Injection engines 

 High impedance fuel injectors (10 ohms ore more)  

 The car has no misfire detection or has it disabled. If misfire detection is active and RaceTCS 

is connected, Check Engine Light can pop up and indicate damaged ignition coil. 

 Injectors are not PWM controlled  

 

2. RaceTCS functions 

 Keeping wheel slip at Target Slip 

 Keeping RPM at specified threshold 

 

3. RaceTCS operating principle 

 

RaceTCS operates on the principle of wheel speed difference between driven wheels and non-

driven wheels (reference). When the difference exceeds the threshold, RaceTCS takes action to 

limit this difference to level defined by user. This is achieved by reducing torque output from the 

engine. 

As a rule of thumb, most traction is available around 10% slip for dry surface and <5% for wet. 

This corresponds to preset 1-2 in wet and preset 3-4 in dry.  

When torque reduction is needed (RPM limiter or Wheel slip limiter), RaceTCS cuts the impulse 

to injector. It cuts the whole impulse, so no fuel is injected during that power stroke.  

In case of fuel cut, there will be a false lean reading by oxygen sensor (lambda), because instead 

of exhaust fumes, clean air is being pumped to the exhaust. This has minimal effect on the 

mixture in the next power stroke.  

Fuel cut has no negative effect on Exhaust gas temperature and it should allow the cylinder to 

cool with incoming air. 
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4. RaceTCS logic 

 

RaceTCS logic can be divided into 2 functions: 

 RPM limiter – keeps RPM below specified limit 

 Clutch pedal down 

o Car stationary – Launch control RPM limit (if enabled via Enable LC) 

o Car moving – Flat shift RPM limit (if enabled via Enable FS) 

 Clutch pedal up 

o Car speed below Activation Speed – limit RPM to Start RPM 

 Wheel slip limiter – keeps wheel slip at specified limit 

 Car speed above Activation Speed  and RPM above Activation RPM  - torque reduction 

on slip severity 

o Slip <= Target Slip  - 0% cut 

o Slip >= Maximum Slip  - 100% cut (or Max slip fuel cut, whichever is smaller) 

o Slip between Target Slip and Maximum Slip – torque reduction depending on road 

conditions, trying to maintain slip close to Target Slip 

 
RaceTCS RPM/Wheel slip control 
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5. RaceTCS package 

 

RaceTCS device with accessories 
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Installation schematics 

 

RaceTCS connection with ABS  

 

RaceTCS connection without ABS  

 

Potentiometer for Preset selection 
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 +12 – power supply with ignition  

 GND ( ground) – connect to common ground with separate wire 

 DiodeOut 

 Indicates current RaceTCS setting. When user changes settings via potentiometer, diode 

will blink indicating current preset (1-6). When RaceTCS is completely off, the diode will 

be constantly on. 12V LED should be connected to this output with negative end, while 

positive end should be connected to +12 

When RaceTCS is active and wheel slip is detected, it will also indicate this condition 

by blinking the LED 

In case of a factory handbrake indication on the dashboard with a simple switch, it is 

possible to connect this output in parallel to this switch, to have RaceTCS indication 

on the dash.  

 Can be used to output digital signal (PWM) informing about requested slip fuel cut and 

selected preset. 1000us period indicates preset1, 950us - preset2, 900us - preset3, 850us – 

preset4, 800us – preset5, 750us – preset6, 700us - tcs off. PWM duty indicates slip fuel 

cut, 0% PWM = 0% fuel cut,90% PWM = 100% fuel cut  

 ClutchIn –clutch switch input. This is mandatory if Flat Shift or Launch Control needs to be 

used.  ClutchIn can use 4 input signals: 

 0 – clutch press shorts to ground 

 1 – clutch press disconnects ground (normally short to ground) 

 2 – clutch press shorts to +12 

 3 – clutch press disconnects +12 (normally short to +12) 

 ClutchIn can be used as analogue output 0-5V (PWM 1 kHz). Might require additional 

RC filter, depending on other device input filter.  

 

 FrontLeft – wheel sensor input for front left wheel  

 FrontRight – wheel sensor input for front right wheel  

 RearLeft – wheel sensor input for rear left wheel  

 RearRight- wheel sensor input for rear right wheel 

Wheel speed signals – it is most convenient to pick up signals near ABS pump main 

connector. Each sensor cable consists of 2 wires.  

VR sensors will have one wire short to ground when connected to ABS pump (and ignition is 

on), and one hot, so identifying the hot wire is easy when ignition is on. With VR (variable 

reluctance) sensor, hot wire will have sinusoidal signal and the other one will have contact to 

ground.  

In case of Hall sensor (found in modern cars manufactured after 2000), you need to find signal 

wire. Voltage should oscillate on the signal wire when you move the car a little. If voltage is 

outside RaceTCS operating range (above 5V), you will have to install a series resistor on 

ground wire to the sensor and pick up the signal between the resistor and sensor. Please refer 
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to schematics above. Hall sensor flows variable current, so voltage drop on that resistor is the 

pickup signal for RaceTCS. They usually work with 1V ABS ref vol. 

Some Hall sensors have 3 wires, +12/Ground/Signal. 3rd wire is signal pickup. These sensors 

work best with 2.5V ABS ref. vol., because they switch between 0 and supply voltage. 

Use shielded or twisted pair cable for ABS signals!  

 GND (Power) – power ground for injectors. It is internally connected with normal GND, but 

this one is close to transistors and it is recommended to have a thicker wire or 2 wires that will 

support 5-10A current (0.75mm2 or 1mm2). Each GND wire should be separate and they 

should join in a common grounding point (engine block). 

 InjOut1-8 – injector output (ground). Connect it to injectors, as RaceTCS will operate the 

injectors instead of original ECU. Use 0.5mm2  wires. 

 PotIn – potentiometer input (10kOhm). Only 2 out of 3 connectors in potentiometer are used, 

because potentiometer works as adjustable resistor in this application. Connection order is not 

important. Potentiometer has 11 positions, each position selects different preset: 

Position 1-2: preset1 

Position 3: preset2  

Position 4: preset3  

Position 5: preset4  

Position 6: preset5 

Position 7: preset6 

Position 8-11: RaceTCS inactive 

When potentiometer is disconnected, it selects preset1 as default (safe setting).  

Each preset is indicated by LED blinks, number of blinks represents a preset. Preset 1 - 1 

blink, preset 6 - 6 blinks. When RaceTCS is inactive, LED will be on all the time. 

If you connect potentiometer using left (crossed out) pin, it will work in other direction. 

Maximum to the right will select preset 1, maximum to the left RaceTCS inactive. 

 InjIn1-8 – injector input (ground controlled injectors). ECU output for injectors should be 

connected to InjIn 

Supplied RaceTCS connectors are detachable for easier connection. Make sure wires are 

tight and secure to avoid problems. Spring loaded connectors work better with bare wire 

(no soldering).  

 

RaceTCS connectors are spring loaded. To connect a wire, remove around 10mm of 

insulation and push the wire into connector. Pull it to verify it is secure. To remove the 

wire from connector, press the orange button above the wire with a screwdriver, then 

pull the wire from the connector. See FAQ section for images. 
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6. PC application – RaceTCS Configurator 

RaceTCS configurator is a portable application. It means you do not install it on your PC, just 

download the zip file and unpack (extract) the content to a folder. You should see following 

folder content. Run RaceTCSConfiguratorV2.exe to start the application. 

 

 

PC app requires  .Net framework 3.5 (Windows 7 and higher have it preinstalled) 
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Main functions of RaceTCS Configurator 

 Read from device - reads configuration from connected device 

 Save to device - saves config to device and restarts RaceTCS. It is recommended to do this 

while engine is off 

 File->Save/Load settings - allow to save/load settings on your computer 

 Each setting in PC app has a tooltip – hover mouse over to see the explanation 

 

 

 PC app is used to configure RaceTCS. The most important settings are wheel size and ABS 

tooth count. To verify these settings are correct, open Logging tab and run a log while the car 

is moving straight without any wheel spin. All wheel speed should be identical and 

similar/equal to speedometer/GPS. 

 Auto load default settings on start feature – when RaceTCS configurator is opened, it looks for 

default.xml file in Settings folder. If it cannot find that file, it loads hardcoded settings. If you 

store your RaceTCS settings as default.xml file, it will be always loaded when application 

starts. 
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Logging 

After logging is started (play icon) current readings will be displayed live. All logs are 

automatically saved to Log directory in the main app directory. Each log start will create file 

name with date and time. Log can be opened in RaceTCS Configurator for later analysis or sent 

to support. Log channels can be show/hidden by clicking on channel text.  

 

 

 

 



RaceTCS V2 User Manual  2023-07-14 

 

 Page 12  

 

7. Configuring RaceTCS 

To correctly configure your RaceTCS for the 1st time, please follow these steps: 

 Run PC application 

 Load settings for your car (if available) from File-> Load settings menu. If not available, start 

with default settings (loaded when PC application starts) 

   

 

 Reset pot calibration – turn pot to OFF position (max right) and press File->Reset pot 

calibration 

 Configure wheel sizes. Current wheels to all button copies wheel settings from Front left 

wheel to all 4 wheels.  

 Current to all except slip button copies current preset settings to all presets, except slip 

settings (Target Slip, Maximum Slip, Minimum speed difference) 

 Verify that each preset has correct wheel setting by selecting “Current preset” from 1 to 6. 

 Save the settings from File->Save settings for future use.  
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 When you connect your PC to RaceTCS device and turn ignition on for the 1st time, load your 

saved settings (previous step) and press “Save to device” button you should see a 

confirmation message.  

 

 

 

 If your RaceTCS is not powered or not correctly connected, you can see error message when 

trying to save  

 

 

This can indicate also that USB drivers are not installed on your system. You can try 

installing newest drivers for FTDI VCP https://www.ftdichip.com/Drivers/VCP.htm 

 

 If you correctly save settings to your RaceTCS device, you can verify that all is set up 

correctly. Go to logging tab and press start log button.  

 

 

 

https://www.ftdichip.com/Drivers/VCP.htm
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You should see a log being displayed. Log file is automatically saved to Logs folder. 

 

 

 

 Now you can start the engine and drive around a bit. Verify, that wheel speeds are identical (or 

very close to each other) while driving at constant speed in a straight line. It should look like 

in the picture below: 
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 If you have difference between wheels, verify that tire size settings match your tires on the car 

and ABS tooth count is correct. If you do not know the correct ABS tooth count, you can just 

change the settings, save to device and start the log again to verify. Remember to copy wheel 

settings to all presets after each change.  

Picture below shows an incorrect setting - rear wheel speed is higher than front 

 

 

 One possible mistake is incorrect ABS reference voltage setting. With VR sensor the result 

will be no speed detection until speed is high, for Hall sensor signal might be unreliable, like 

in picture below 
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 If everything with wheel size is correct, you can try accelerating so that you lose traction. It 

should be visible in a log. Wheel speed between driven wheels and reference wheels should be 

different (blue lines), slip should be indicated by pink line and fuel cut by green line 

 

 Setting up Start RPM and Launch Control requires trial and error. Best approach is to 

accelerate in 1st gear from 1000 RPM and see, when engine has enough power to cause wheel 

to slip. In example below this happens around 3500, so we chose Launch Control to be 3700 

for better turbo spool and Start RPM 3300 (when clutch is engaged and car is starting to 

move).  
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 We used 3700 RPM for Launch Control to have around 0.5 bar of boost. After clutch is 

released, we use Start RPM of 3300. At 3300 RPM car has around 28km/h. We chose 24km/h 

as activation speed (speed at which Start RPM limit is inactive and wheel slip control 

activates). Launch Control RPM should be around the RPM, where engine has enough torque 

to spin the wheels (picture above). Start RPM should be as low as possible, where engine can 

maintain slip.  

 

 If you set Launch Control RPM to a too low value, then the start will be slow, because engine 

torque will not be enough to maintain slip. Also make sure that Start RPM is at least 5% above 

RPM that you have at Activation Speed. Otherwise switch from RPM Control to Slip Control 

will not be smooth or car might stop accelerating before reaching Activation Speed.  
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8. Firmware update 

 

To update firmware, select File menu, Firmware Update and select firmware file to be updated. 

Green progress bar will indicate when process is finished. RaceTCS should automatically 

restart, so do not update firmware when engine is running  

 

When application is launched and newer version is found on webpage, a popup will show.  

When you read settings from RaceTCS and newer firmware is available for update, a popup will 

show. Make sure to use newest firmware available, as new features are added. Change log is 

available in Help->About menu. 
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9. FAQ 

 How to use RaceTCS connectors 

 RaceTCS connectors are detachable for easier installation. They have no locking 

mechanism, just pull them from the socket. To correctly put a wire in the connector, you 

have to take around 10mm of insulation from wire and push it into connector. Do not 

twist exposed wire, just push it as much as you can, and pull to verify it is tight. Correctly 

installed wire will be very hard to pull. To detach wire from the connector, push orange 

button above the wire and pull the wire. 

  

 

 How to connect 2 wire hall sensor to RaceTCS without ABS?  

 Refer to schematics below. For most sensors ABS ref voltage should be set to 1V 

 How to connect VR sensor to RaceTCS without ABS? 

 Refer to schematics below. For VR sensors ABS ref voltage should be set to 0V 

 How to connect 3 wire hall sensor to RaceTCS without ABS? 

 Refer to schematics below. For 3 wire hall sensor ABS ref voltage should be set to 2.5V 

 Everything seems to be set up correctly, but RaceTCS is not controlling wheel spin 

 Make sure clutch signal is low (0) when clutch is engaged. When you press on clutch 

pedal with your foot, it should indicate high (1) in the log. Refer to log screenshots in 

section 6 

 



RaceTCS V2 User Manual  2023-07-14 

 

 Page 20  

 

 

RaceTCS connection without ABS  

 How to connect 2 wire hall sensor to RaceTCS with ABS? 

 You need to solder a resistor in series on ground wire and pickup signal after the resistor. 

This is very common in cars manufactured 2010+. Please refer to schematic in page 5. 

 

 How to connect VR sensor to RaceTCS with ABS? 

 Find which wire is signal and connect RaceTCS wheel input from there. Use shielded 

wire with shield attached to GND on just one end. Some sensors have a voltage offset, if 

ABS ref. voltage 0V does not work, try different value until you see a signal. 
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 I cannot connect my laptop with RaceTCS 

 RaceTCS needs to be powered with +12V to be able to connect. Please check that when 

you connect RaceTCS with USB cable, device is visible in Windows “Device Manager” 

as USB serial port  

 

If that is not visible, please check if usb device is visible as USB serial 

converter and in it’s properties, Load VCP is checked 

 

If this does not help, please try installing drivers from FTDI website : 

https://ftdichip.com/drivers/vcp-drivers/ 

 How to connect and configure RaceTCS when I have only one gearbox output shaft 

speed sensor? 

https://ftdichip.com/drivers/vcp-drivers/
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 Connect sensor signal to both left and right wheel speed input. Configure abs tooth count 

to a value of trigger tooth count * diff ratio. So if you have 40 tooth and 3.42 diff, this 

gives 137. 

 I connected RaceTCS as in schematic, device works, USB connection works, but my car does 

not start. What can be wrong? 

 Make sure +12V is uninterrupted source (preferably fed from stock ecu). Some circuits 

get turned off during cranking. If RaceTCS is connected to such a circuit, the engine 

won’t start. You can verify it easily, put RaceTCS pot in OFF position, LED should be 

constantly on. While your crank the engine, LED should stay on all the time. If it goes 

off, it means power supply is not correct. 

 My potentiometer seems to be a bit off, preset selection is not precise 

 Reset pot calibration – if preset selection via potentiometer is inaccurate, you can reset 

pot calibration. Move it to far right (RaceTCS off) and press File->Reset pot calibration 

menu button. This will reset pot calibration.  

 What wire thickness should I use? 

 Use 0.5mm2 (20AWG) for all the wires except GND connection. GND should use 1mm2 

(17AWG). Make sure to have 3 separate GND wires connecting to a common grounding 

point. 

 RaceTCS limits my RPM when car is stationary, even though LC is disabled. 

 There is a 2 step RPM limit called StartRPM. It limits RPM before car reaches activation 

speed. You can check StartRPM when moving to activate it only when car is moving or 

increase StartRPM beyond ECU RPM limit to disable this feature completely. 
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10. Car specific schematics  

Schematics below are supposed to help with installation in common cars. It does not mean that 

cars not listed here are not supported. The list will grow as we get more customers asking for 

support with installation 

a. Nissan 350Z 

ECU diagrams  
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VDS/TCS/ABS Diagrams 
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b. Nissan 300ZX 
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c. Opel Speedster/VX220 turbo 

 

There is a DYI guide for VX220 made by VX220.org.uk members.  

https://racetcs.com/files/DIY%20Guide%20VX220.pdf 

 

https://racetcs.com/files/DIY%20Guide%20VX220.pdf
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d. BMW E36 

 

FL signal – 37, RL signal – 34, FR signal – 15, RR signal - 35 

 

FL signal – 1, RL signal – 6, FR signal – 19, RR signal – 22 
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FL signal – 48, RL signal – 46, FR signal – 47, RR signal – 45 
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e. BMW E46 

BMW E46 uses hall sensors with built in resistor in ABS pump on +12 line. RaceTCS requires 

signal on ground wire, so a series resistor (~ 100ohm) is needed to be added. 

 

 

Hall sensor connection with abs 

 

There are 4 different ASC/DSC pumps with different pinouts, but all share the same wiring 

colors. 

FR – BR GE (solder resistor on BR) 

FL – BR BR/RT (solder resistor on BR) 

RR – GE/BR GE/SW ( solder resistor on GE/BR) 

RL – BR BL (solder resistor on BR) 

 

braun BR = brown 

blau BL = blue 

rot RT = red 

gelb GE = yellow 

grau GR = gray 

schwarz SW = black 

weiss (weiß ) WS = white 

grun GN = green 

orange OR = orange 

rosa RS = pink 

violett VI = violet 
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FR ground – 19, FL ground – 1 , RR ground – 23, RL ground  - 5 
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f.  Mazda RX8 

Mazda RX8 pre R3 used VR sensors on all wheels.  

Wire colors and pin position in ABS/DSC connector is shown on a diagram below: 

 

 

 

 



RaceTCS V2 User Manual  2023-07-14 

 

 Page 35  

 

g. Mazda MX5 NC (pre-lift) 

MX5 MK3 (according to user reports) uses Hall sensors. Signals alternate between 0.5 and 1V, 

so there is no need for a resistor. ABS Ref voltage should be set to 0.76V. 

h. Mazda MX5 NC 2012+  

MX5 MK3.5 and up use Hall effect sensors (the same is with RX8 R3 version). You need to 

solder 100ohm resistor on ground wire and connect signal pickup between Resistor and wheel 

sensor 
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i. Ford Mustang GT 5th gen 

 

 

 


